source: README @ ea0c453

release-1.10release-1.9
Last change on this file since ea0c453 was a8c55b5, checked in by David Benjamin <davidben@mit.edu>, 12 years ago
Use Digest::SHA in Jabber module instead of Digest::SHA1 The cool kids spell it without the 1 these days. More precisely, Digest::SHA1 no longer exists in precise. Also it's in perl itself these days. (We can just install Digest::SHA into the locker for the sysnames that need it.)
  • Property mode set to 100644
File size: 902 bytes
RevLine 
[6a6dd47]1BarnOwl - owl, with more ponies
2
[aeadc74]3Source is freely available from http://github.com/barnowl/barnowl/
4
[6a6dd47]5Based on owl 2.1.11, by James Kretchmar (http://www.ktools.org)
6
7Notes:
8-----
[b711711]9This project's perl/modules/ contains the lib directories from the
[6a6dd47]10following CPAN modules:
11
[bbd0cf1]12AnyEvent::HTTP
13Facebook::Graph
[6a6dd47]14Net::Jabber
15Net::XMPP
[bbd0cf1]16Ouch
17URI::Encode
[6a6dd47]18XML::Stream
19
[bbd0cf1]20Some have been modified slightly for the needs of this project.
[723f464]21
22BarnOwl currently requires the following perl modules off of CPAN:
23
[13ee8f2]24AnyEvent
[5b24dc0]25Class::Accessor
[9179fd7]26Glib
[6933082]27PAR
[723f464]28
29(Note that these are all available as Debian packages)
30We plan to soon add targets to the Makefile to check for and install
31these for you.
[6824a76]32
33The IRC module requires:
34
[13ee8f2]35AnyEvent::IRC
[5b24dc0]36
37The Jabber module requires:
38
39Net::DNS
40Authen::SASL::Perl
41IO::Socket::SSL
[a8c55b5]42Digest::SHA
[62c91c1]43
[9c58232]44The Twitter module requires:
45
46HTML::Entities
47Net::Twitter::Lite
48
[62c91c1]49The WordWrap module requires:
50
51Text::Autoformat
Note: See TracBrowser for help on using the repository browser.