source: README @ 5b24dc0

release-1.8release-1.9
Last change on this file since 5b24dc0 was 5b24dc0, checked in by David Benjamin <davidben@mit.edu>, 10 years ago
Fix up dependencies in README file Class::Accessor is a dependency of the core code. Also, most of the ones listed are Jabber module dependencies, so we may as well list them as such. Reported-by: William Throwe <wthrowe@mit.edu>
  • Property mode set to 100644
File size: 786 bytes
Line 
1BarnOwl - owl, with more ponies
2
3Source is freely available from http://github.com/barnowl/barnowl/
4
5Based on owl 2.1.11, by James Kretchmar (http://www.ktools.org)
6
7Notes:
8-----
9This project's perl/lib/ contains the lib directories from the
10following CPAN modules:
11
12Net::Jabber
13Net::XMPP
14XML::Stream
15
16They have been modified slightly for the needs of this project.
17
18BarnOwl currently requires the following perl modules off of CPAN:
19
20AnyEvent
21Class::Accessor
22Glib
23PAR
24
25(Note that these are all available as Debian packages)
26We plan to soon add targets to the Makefile to check for and install
27these for you.
28
29The IRC module requires:
30
31AnyEvent::IRC
32
33The Jabber module requires:
34
35Net::DNS
36Authen::SASL::Perl
37IO::Socket::SSL
38Digest::SHA1
39
40The WordWrap module requires:
41
42Text::Autoformat
Note: See TracBrowser for help on using the repository browser.