source: debian/rules @ 2f205a7

debian
Last change on this file since 2f205a7 was 485d885, checked in by Sam Hartman <hartmans@mit.edu>, 15 years ago
Disable cdbs configure handling CDBS fails to handle aclocal correctly because it will only create it if it exists. The upstream tarball has a configure. WE'll use that and run autoreconf (and include the results in the diff) if necessary. Also, disable dh_clean removal of autom4te.cache. It's broken that the upstream tarball includes this, but cleaning it up produces problems for the diff and git-buildpackage.
  • Property mode set to 100755
File size: 500 bytes
Line 
1#!/usr/bin/make -f
2
3DEB_CLEAN_EXCLUDE+=autom4te.cache
4
5
6include /usr/share/cdbs/1/rules/debhelper.mk
7include /usr/share/cdbs/1/class/autotools.mk
8
9DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
10CFLAGS += -DOWL_VERSION_STRING=\"\\\"$(shell dpkg-parsechangelog | sed -ne 's/Version: //p')\\\"\" -D_FORTIFY_SOURCE=2
11
12clean::
13        rm -f perl/modules/Jabber/Makefile.old
14        rm -f perl/modules/Jabber/Jabber.par
15        rm -f perl/modules/IRC/Makefile.old perl/modules/WordWrap/Makefile.old
16        rm -f perl/modules/IRC/IRC.par
Note: See TracBrowser for help on using the repository browser.