source: debian/rules @ 94cb84ff

barnowl_perlaimdebianrelease-1.10release-1.4release-1.5release-1.6release-1.7release-1.8release-1.9
Last change on this file since 94cb84ff was 94cb84ff, checked in by Sam Hartman <hartmans@mit.edu>, 17 years ago
Owl debian directory as it appears in debian on 2007-03-03
  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# This is the debhelper compatibility version to use.
9export DH_COMPAT=3
10
11# These are used for cross-compiling and for saving the configure script
12# from having to guess our platform (since we know it already)
13DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
14DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
15
16
17ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
18        CFLAGS += -g
19endif
20ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21        INSTALL_PROGRAM += -s
22endif
23
24config.status: configure
25        dh_testdir
26        # Add here commands to configure the package.
27        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
28
29
30build: build-stamp
31
32build-stamp:  config.status
33        dh_testdir
34
35        # Add here commands to compile the package.
36        $(MAKE)
37        #/usr/bin/docbook-to-man debian/owl.sgml > owl.1
38
39        touch build-stamp
40
41clean:
42        dh_testdir
43        dh_testroot
44        rm -f build-stamp
45
46        # Add here commands to clean up after the build process.
47        -$(MAKE) distclean
48
49        dh_clean
50
51install: build
52        dh_testdir
53        dh_testroot
54        dh_clean -k
55        dh_installdirs
56
57        # Add here commands to install the package into debian/owl.
58        # $(MAKE) install prefix=$(CURDIR)/debian/owl/usr
59        cp owl $(CURDIR)/debian/owl/usr/bin/
60
61# Build architecture-independent files here.
62binary-indep: build install
63# We have nothing to do by default.
64
65# Build architecture-dependent files here.
66binary-arch: build install
67        dh_testdir
68        dh_testroot
69#       dh_installdebconf       
70        dh_installdocs doc/intro.txt
71        dh_installexamples
72        dh_installmenu
73#       dh_installlogrotate
74#       dh_installemacsen
75#       dh_installpam
76#       dh_installmime
77#       dh_installinit
78        dh_installcron
79        dh_installman doc/owl.1
80        dh_installinfo
81#       dh_undocumented
82        dh_installchangelogs ChangeLog
83        dh_link
84        dh_strip
85        dh_compress
86        dh_fixperms
87#       dh_makeshlibs
88        dh_installdeb
89#       dh_perl
90        dh_shlibdeps
91        dh_gencontrol
92        dh_md5sums
93        dh_builddeb
94
95binary: binary-indep binary-arch
96.PHONY: build clean binary-indep binary-arch binary install
Note: See TracBrowser for help on using the repository browser.