Changeset 9506feb for perl


Ignore:
Timestamp:
Jan 10, 2008, 1:43:11 AM (13 years ago)
Author:
Nelson Elhage <nelhage@mit.edu>
Branches:
master, barnowl_perlaim, debian, release-1.4, release-1.5, release-1.6, release-1.7, release-1.8, release-1.9
Children:
635881c
Parents:
1151f0b
Message:
Make :reload-modules work correctly with PARs
File:
1 edited

Legend:

Unmodified
Added
Removed
  • perl/lib/BarnOwl/ModuleLoader.pm

    rbe98ba5 r9506feb  
    99
    1010sub load_all {
     11    PAR::reload_libs();
    1112    my %modules;
    1213    my @modules;
     
    3637    for my $class (keys %modules) {
    3738        if(!defined eval "use BarnOwl::Module::$class") {
    38             BarnOwl::error("Unable to load module $class: $!") if $!;
     39            # BarnOwl::error("Unable to load module $class: $!") if $!;
    3940            BarnOwl::error("Unable to load module $class: $@") if $@;
    4041        }
Note: See TracChangeset for help on using the changeset viewer.