Changeset c60ade2


Ignore:
Timestamp:
Jan 2, 2008, 1:56:33 PM (13 years ago)
Author:
Alejandro R. Sedeño <asedeno@mit.edu>
Branches:
master, barnowl_perlaim, debian, release-1.4, release-1.5, release-1.6, release-1.7, release-1.8, release-1.9
Children:
e23eb2b
Parents:
47519e1b
Message:
* set min glib version to 2.12.0
 - first to support Unicode 5.0

* added glib_compat.c with our own implementation of
  g_unicode_ismark() for glib < 2.14
Files:
1 added
2 edited

Legend:

Unmodified
Added
Removed
  • Makefile.in

    r47519e1b rc60ade2  
    2626     keypress.c keymap.c keybinding.c cmd.c context.c zcrypt.c \
    2727     aim.c buddy.c buddylist.c timer.c style.c stylefunc.c errqueue.c \
    28      zbuddylist.c muxevents.c popexec.c obarray.c wcwidth.c
     28     zbuddylist.c muxevents.c popexec.c obarray.c wcwidth.c glib_compat.c
    2929OWL_SRC = owl.c
    3030TESTER_SRC = tester.c
  • owl.c

    r47519e1b rc60ade2  
    8686  int newstderr;
    8787#endif
     88 
     89  if (!GLIB_CHECK_VERSION (2, 12, 0))
     90    g_error ("GLib version 2.12.0 or above is needed.");
    8891
    8992  argcsave=argc;
Note: See TracChangeset for help on using the changeset viewer.