Changeset db4f7c3


Ignore:
Timestamp:
Jun 11, 2011, 6:31:32 PM (10 years ago)
Author:
David Benjamin <davidben@mit.edu>
Children:
6dc3757
Parents:
431fcd8
git-author:
David Benjamin <davidben@mit.edu> (06/11/11 16:16:55)
git-committer:
David Benjamin <davidben@mit.edu> (06/11/11 18:31:32)
Message:
Bump required glib version to 2.16

Debian Lenny's version is 2.16.6-3 and Ubuntu Hardy's is
2.16.6-0ubuntu1.2. Also remove the version check in main; it never did
anything useful as GLIB_CHECK_VERSION is evaluated at compile-time.
Files:
1 deleted
3 edited

Legend:

Unmodified
Added
Removed
  • Makefile.am

    r3535a6e rdb4f7c3  
    4545     aim.c buddy.c buddylist.c style.c errqueue.c \
    4646     zbuddylist.c popexec.c select.c wcwidth.c \
    47      glib_compat.c mainpanel.c msgwin.c sepbar.c editcontext.c signal.c
     47     mainpanel.c msgwin.c sepbar.c editcontext.c signal.c
    4848
    4949NORMAL_SRCS = filterproc.c window.c windowcb.c
  • configure.ac

    rf97c1a6 rdb4f7c3  
    115115
    116116dnl Add CFLAGS and LIBS for glib-2.0
    117 PKG_CHECK_MODULES(GLIB,[glib-2.0 >= 2.12 gobject-2.0 gthread-2.0])
     117PKG_CHECK_MODULES(GLIB,[glib-2.0 >= 2.16 gobject-2.0 gthread-2.0])
    118118
    119119AC_MSG_NOTICE([Adding glib-2.0 CFLAGS ${GLIB_CFLAGS}])
  • owl.c

    rcc305b5 rdb4f7c3  
    486486  GSource *source;
    487487
    488   if (!GLIB_CHECK_VERSION (2, 12, 0))
    489     g_error ("GLib version 2.12.0 or above is needed.");
    490 
    491488  argc_copy = argc;
    492489  argv_copy = g_strdupv(argv);
Note: See TracChangeset for help on using the changeset viewer.