Opened 11 years ago

Closed 10 years ago

#161 closed defect (fixed)

commands in startup which request input fail oddly

Reported by: kevinr@mit.edu Owned by:
Priority: minor Milestone:
Component: internals Keywords:
Cc:

Description

If I put, at the end of my ~/.owl/startup, a command which requests user input, eg.

jabberlogin kevinr@free-dissociation.com

(which doesn't do Kerberos authentication; it asks for a password), when I run BarnOwl, it appears to work (or at least doesn't error visibly).

I don't see the "you're now logged into kevinr@free-dissociation.com/owl" message, though, so I get suspicious and run it again by hand. This results in the error:

[Error] Error in connect: error not-authorized

That's odd, it never even asked for my password! So in a fit of insanity (technical definition) I run it again, and *this* time it asks me for my password and lets me log into Jabber successfully.

It used to be that including that line at the end of my startup file would cause the password prompt to appear and accept input when I started BarnOwl. We should either return to that behavior or completely prohibit input-requesting commands in the startup file.

Change History (1)

comment:1 Changed 10 years ago by davidben@mit.edu

  • Resolution set to fixed
  • Status changed from new to closed

This should not have taken so long. Fixed in 389d48749c4eb68f218e9fd6faf953ba542bfb75.

Note: See TracTickets for help on using tickets.