Opened 9 years ago

Closed 9 years ago

#54 closed defect (fixed)

owl doesn't like filters that use a subfilter twice

Reported by: geofft@MIT.EDU Owned by: nelhage@mit.edu
Priority: major Milestone:
Component: internals Keywords:
Cc:

Description

To reproduce:

:vu geofft
:vu nelhage
:view -d filter user-geofft or filter user-nelhage

Or even

:view -d filter personal or filter personal

It looks like owl_filterelement_is_toodeep does very much the wrong thing, and tries to determine if a filter ever contains a subfilter twice, which it seems to think is indicative of an infinite loop. Instead, it should recursively call itself, and check the recursion depth against OWL_FILTER_MAXRECURSE,

This blocks narrowing to CCs (see git://geofft.scripts.mit.edu/barnowl wip commit e5ca501), since that filter uses the personal filter once for each CC'd user.

Change History (1)

comment:1 Changed 9 years ago by nelhage@MIT.EDU

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.