Opened 12 years ago

Closed 12 years ago

#56 closed defect (fixed)

Trac Search error

Reported by: jdaniel@MIT.EDU Owned by: nelhage@mit.edu
Priority: major Milestone:
Component: internals Keywords:
Cc:

Description

ProgrammingError: (1146, "Table 'barnowl+trac.revision' doesn't exist")

How to Reproduce

While doing a GET operation on /search, Trac issued an internal error.

Type a pattern such as "alert" into the search box on any trac page and click Search

Request parameters:

{'q': u'alert'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

System Information

Trac 0.11.1
Python 2.5.1 (r251:54863, Jun 15 2008, 18:24:56)
[GCC 4.3.0 20080428 (Red Hat 4.3.0-8)]
setuptools 0.6c8
MySQL server: "5.0.67-log", client: "5.0.51a", thread-safe: 1
MySQLdb 1.2.2
Genshi 0.5
Pygments 0.11.1
GIT 1.5.6.5
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/afs/sipb.mit.edu/project/barnowl/web_scripts/trac/install/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/afs/sipb.mit.edu/project/barnowl/web_scripts/trac/install/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "/afs/sipb.mit.edu/project/barnowl/web_scripts/trac/install/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/search/web_ui.py", line 106, in process_request
    results += list(source.get_search_results(req, terms, filters))
  File "/afs/sipb.mit.edu/project/barnowl/web_scripts/trac/install/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/versioncontrol/web_ui/changeset.py", line 966, in get_search_results
    "FROM revision WHERE " + sql, args)
  File "/afs/sipb.mit.edu/project/barnowl/web_scripts/trac/install/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib64/python2.5/site-packages/MySQLdb/cursors.py", line 166, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.5/site-packages/MySQLdb/connections.py", line 35, in defaulterrorhandler
    raise errorclass, errorvalue
ProgrammingError: (1146, "Table 'barnowl+trac.revision' doesn't exist")

Change History (1)

comment:1 Changed 12 years ago by nelhage@MIT.EDU

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report. Looks like this was caused by our use of the git vcs plugin; Fixed, although you still can't use the website to search through source.

Note: See TracTickets for help on using tickets.