Opened 13 years ago

Closed 13 years ago

#28 closed defect (fixed)

alt-n problem with unclasses

Reported by: baniszew Owned by: nelhage@MIT.EDU
Priority: minor Milestone:
Component: zephyr Keywords:
Cc:

Description

When I alt-n on an unclass, it shows me the class, but not the unclass. Further investigation shows that this bug only happens with certain classes. So far, ones with 3 and 4 letter class names are showing both the class and the unclass, ones with longer names are showing only the class.

Change History (3)

comment:1 Changed 13 years ago by nelhage@MIT.EDU

Can you list a specific class you've observed this on? I haven't heard any other reports of this, and I M-n on unclasses of long classes all the time.

comment:2 Changed 13 years ago by anonymous

Confirmed problem. This is a problem of a filter of the form class-foo existing prior to smart-narrow, in this particular instance for coloring purposes. Works great in owl because it doesn't try to be clever with unclasses and .d classes.

comment:3 Changed 13 years ago by nelhage@MIT.EDU

  • Resolution set to fixed
  • Status changed from new to closed

I think this gets rolled into the we-need-to-rethink-our-magic-smartnarrow deal.

Note: See TracTickets for help on using tickets.