Opened 13 years ago

Closed 10 years ago

#38 closed defect (fixed)

Narrowing fails with daemon messages for printer error

Reported by: ranson@MIT.EDU Owned by: nelhage@mit.edu
Priority: minor Milestone:
Component: zephyr Keywords:
Cc: davidben@mit.edu

Description

M-n narrowing shows no messages and displays info bar text "(1/0/116) user-daemon" for the following message:

-> Zephyr from daemon [AUTO] 15:17 (maia)

Printer Error: maia may need attention:

Load Letter paper' into the LC/Lower/Tray3' tray

Change History (5)

comment:1 Changed 12 years ago by adehnert@MIT.EDU

Does anyone know how this could be reproduced? Does anyone know if it still can be reproduced that way? I'm inclined to suspect that this might have been fixed sometime in the past 19 months...

comment:2 Changed 12 years ago by kchen@MIT.EDU

This should work for reproducing:

Go to an Athena cluster, remove the paper from an HP printer, and close the printer trays. Print to that printer from an Athena 9 machine.

comment:3 Changed 10 years ago by davidben@mit.edu

I think the problem is that the sender of a print daemon message is 'daemon' not 'daemon@ATHENA.MIT.EDU' as we try to match. We currently short_zuser the sender or recipient and use that to name the filter and then long_zuser the shortened form in the filter.

Is there any reason why we don't pass the sender/recipient as-is? It may also be worthwhile to stick the realm into the filter name or we'll run into trouble with the same username appearing in multiple realms.

comment:4 Changed 10 years ago by nelhage@mit.edu

Yeah, I suspect we want to just use the actual sender in the filter.

As for sticking the realm into the filter name, note that short_zuser only strips the local realm, so I don't think there's actually a risk of users in different realms colliding in the same filter.

comment:5 Changed 10 years ago by davidben@mit.edu

  • Cc davidben@mit.edu added
  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in 811644f3912f5278edb8dcb964547f041976150e.

As for sticking the realm into the filter name, note that short_zuser only strips the local realm, so I don't think there's actually a risk of users in different realms colliding in the same filter.

Ah, okay. Although, it seems daemon and daemon@ATHENA.MIT.EDU will still conflict here?

Note: See TracTickets for help on using tickets.